В Google Play вступили в силу новые требования к целевому API приложений.

В Google Play вступили в силу новые требования к целевому API приложений.

В апреле этого года Google анонсировала новые требования к разработчиками в Google Play, которое теперь обязывает их обновлять SDK своих приложений в течение одного года после выхода последнего крупного обновления ОС Android. 

Начиная с 1 ноября 2022 года, если приложение не нацелено на уровень API 30 (Android 11) или выше, то новые пользователи с более новыми версиями ОС Android не смогут найти или установить данное приложение в Google Play. 

Т.е. приложение с SDK старее 30 будет недоступно для новых пользователей с Android 11 и выше, которые никогда ранее его не устанавливали. А те, кто до этого уже пользовались этим приложением, по-прежнему будут иметь к нему доступ.

Для новых же приложений, еще не опубликованных в Google Play, еще с августа действует требование на целевой уровень API 31. 

Более того, обновления для существующих приложений тоже должны быть нацелены на уровень API 31 (Android 12.0) или выше, иначе разработчи не смогут их загрузить.

Так что, если какой-нибудь разработчик, приложение которого имеет целевой API 30, захочет загрузить обновление в Google Play, то он будет обязан обновить его SDK на уровень 31. 

Полная информация по срокам приведена в таблице ниже:

При этом, если разработчикам существующих приложений для перехода на новый API Android потребуется немного больше времени, они могут запросить одноразовое продление срока на 6 месяцев. Если вы разработчик, то ознакомьтесь с инструкцией по обновлению API.

Требования к приложениям на Wear OS

В части приложений на Wear OS требования к новым приложениям и к обновлениям к уже существующим немного более низкие. Все они должны быть нацелены на SDK30, поскольку последняя версия Wear OS 3.0-3.5 базируется на Android 11.